Using Nginx Proxy Manager with pfSense and Proxmox

Just saw your youtube video “Using Nginx Proxy Manager with pfSense, Proxmox, and Docker.”
Maybe you can help me figure this out as seem to be lost in one of the steps. I skipped the certs for now.
I am able to see this Nginx Proxy Manager locally but not ping my websites from the public side.
I have 2 gateways it appears for pfSense but we should use for Nginx correct?

I have Nginx Proxy Manager (NPM) set up in a VM on Proxmox. I am using pfSense as my firewall which is where I think I’m having problems.

  1. Nginx Proxy Manager VM static IP set in ubuntu
  2. pfSense Lan 2 - (PfSense will give out dhcp IPs for my LXC or VMs) non-bridged or bonded traffic
  3. LXCNetworkGW NETWORK2 LXCNetworkGW
  4. Ubuntu VM where my website is

Google A record has my website ip updated correctly.
I cannot ping my website no reply. I was able to do all of this easily until I needed to use the same port 80 for different websites. I tried HaProxy but that seems too complicated for me. I like Nginx Proxy Manager as it seems easier to add websites fast.
My Objective is this:
website1 on lxc port 80 port 443
website2 on lxc port 80 port 443
website3 on lxc port 80 port 443

I need help.

My apologies for such a late reply. I was having issues with my email server in December and never received any notifications that I had a new post here. So a few things for you, the pfsense rules for WAN do seem a little off. You have multiple entries that do the same thing or deal with the same ports and since I believe they work like a pachinko machine the first in to match is where the packet is sent. So maybe the rules at the bottom for Proxmox should be at the top? Also, don’t know about DNS being sent to NPM. I don’t have that in my rules, but I definitely have a different configuration than you. My video is about using this internally, not about using NPM as an externally facing reverse proxy. You might want to see if you can find a video just about that as a first step. Hope some of that helps.

1 Like

solved it

also port forwarding is now off HAProxy handles this